If you appreciate the work done within the wiki, please consider supporting The Cutting Room Floor on Patreon. Thanks for all your support!

Talk:The Legend of Zelda: A Link to the Past

From The Cutting Room Floor
Jump to navigation Jump to search

Cannon Soldier?

I've heard that there's a cannon soldier who is apparently never actually used. You can place him in any level easily with the game editor, and he does look unfamiliar to me. -- Prince Kassad 23:10, 17 May 2010 (EDT)

That's right, yes. There might be other unused enemies, too? --Xkeeper 23:13, 17 May 2010 (EDT)
I think there's an FAQ on GameFAQs about enemies. There may or may not be, but it might be worth digging through to find. As a matter of fact, have people done a lot of poking around on this game to begin with? These are the only two unused things I know of in this game. Surely, there must be more. -- Rick 23:57, 17 May 2010 (EDT)
Nope, this game has been relatively untouched from what I can gather.
And yes there's a quite extensive enemy listing on GameFAQs. It explains the internals of the game quite well, and even describes some of the game bugs (like the one which prevents the Dark World snake's stats from ever being loaded). -- Prince Kassad 00:04, 18 May 2010 (EDT)
I read that one. That was a pretty good read. Well then, I suppose we know what we should do now! I think it's time for some heavy duty investigatin'! Now if I only had something better than Tile Layer Pro to look at stuff... -- Rick 00:14, 18 May 2010 (EDT)
I don't understand why people continue to use TLP when far better/less buggy tools (hint: YY-CHR) have been available for a long time now. It's akin to running NESticle in Windows XP with a 2 GHz CPU; seriously, why? --BMF54123 00:21, 18 May 2010 (EDT)
On my behalf, it's simply ignorance. Now that I know of something better, I'll use it. -- Rick 00:32, 18 May 2010 (EDT)
Do note, however, that most of ALttP's graphics are compressed by default (only Link's graphics are uncompressed). You'll need to find some way to decompress them. -- Prince Kassad 14:02, 18 May 2010 (EDT)

Page Intro Question

"The Legend of Zelda: A Link to the Past is the third game in the long-running Legend of Zelda series, and the first (and with the exception of a few BSX titles, only) 16-bit entry." Just curious - were any of the GBA Zelda games 16-bit? --Aoi 15:11, 18 March 2011 (EDT)

The GBA was a 32-bit system, so nope. Although it should be noted that ALL the BSX titles were 16-bit, so it seems weird to say a few BSX titles. Fizz 20:40, 30 May 2011 (EDT)

Fusoya Decompress

http://fusoya.eludevisibility.org/zelda/index.html

zcompress : "This program can decompress and dump Zelda's graphics, so that they can be modified by your SNES tile editor of choice. The program can then be used to recompress and insert the graphics back into the ROM. It's very similar to what Lunar Magic does with SMW's graphics, just without the GUI. "

==Darkdata 14:20, 18 May 2010 (EDT)

I've been trying to get this freaking thing to work, but it's not playing nice whether or not I run it in DOSBox. -- Rick 23:58, 29 May 2010 (EDT)
Hey, Rick, have you tried using vSNES? That's what I used to finally rip the proper Skull Statue tile, as well as unused duck sprite (and the stuff I found in Equinox, too). --Fo-sig.gifFlying Omelette 00:07, 30 May 2010 (EDT)
Admittedly, no I haven't. I'll get that right off and mess around with it. -- Rick 00:26, 30 May 2010 (EDT)

Unused monster in Japanese game

Is it just me, or is that monster very similar to a Pol's Voice in appearance? Aside from the arms, of course, which remind me more of a Geruta from Metroid. Also, is that palette just an approximation or are we sure it used it? Is it among the overworld monsters or dungeon ones? Needs some more details, if possible, possibly the most interesting thing I've seen and is completely new to me. I thought I knew the game inside out. Fizz 20:40, 30 May 2011 (EDT)

Faces

Is it just me, or does that "mean" face look like a fox of some kind? --Peardian 17:07, 9 June 2011 (EDT)

I think that's just the palette chosen, mainly. I'm not sure about that image, I think a better one might be needed, I'll see if I can get on it. It actually looks more like some kind of shield emblem when I look at it in the tile editor. Fizz 19:50, 14 June 2011 (EDT)

Japanese Chris Houlihan room

As best I can tell, Kokoha is a name, and "himitsu no heya" means "secret room". No idea about the "da yoon" part. And "yoon" isn't even proper romaji. Was it supposed to be yun or youn?

"Kokoha" -> "ここは" -> "here/this place is", "da yoon" -> "だよ~ん"(?) -> a dragged out "is" with an "n" for good measure/funny accent/speech quirk? Although, at least on the "da yoon", I might be wrong. --Xdaniel 14:19, 1 December 2011 (EST)
So, is that from the Japanese ROM, or are you transliterating it manually? If it's the latter, check the ROM for what "da yoon" is supposed to be. -Lilfut

Translation Error in German version

I'm just going to put this tidbit here on the talk page because I don't know where to put it on the actual page, or if it's even notable enough. I saw some pages get "Translation Errors" listed here and there (notably Pokémon Red/Blue), so ehh.

In the German translation, after you've obtained the Bow in the Eastern Palace, once you use up all of your arrows, the item title "Pfeile und Bogen" (Arrows and Bow) becomes "Pfeile" (Arrows); implying you still have arrows, but your bow disappeared. Likely this error stems from an oversight during text placement; when the arrows run out in the English version, the game presumably drops the "& Arrows" bit of the text. Since in German one speaks of "Arrows and Bow", the text "and Bow" is dropped after the arrows run out. --H Hog 13:42, 22 September 2012 (EDT)

Bomb shop stuff

If I had to guess, chances are the NPC is just trying to say a specific line that was repurposed for something else at some point. Check the JP version and see what's up there. --Xk-sig.png Xkeeper (talk) 12:39, 12 November 2012 (EST)

I'm not inclined to think it will be any different, but I'll look into it when I get some time. --MathOnNapkins 12:46, 12 November 2012 (EST)
Okay, so looked into it, and this is the result.
Zelda 3 (J) bomb shop lady 0.png
Translation given in the screenshot description, but rest assured that it matches. Any point in adding this info and screenshot to the actual page, or would it be better to just state that it matches? For reference, here's the plain text version in Japanese 「この先 <− バクダン屋」.
--MathOnNapkins 20:21, 12 November 2012 (EST)

In AST, they actually used these characters in their houses and they say (in the English fan-translation):

Hooded Lady: "Huh? What do you want? By the way, the Magic Shop is looking for mushrooms."
Non-hooded Lady: "Huh? What do you want? By the way, did you know about the cave to the east of town?"

This implies that they say the Bomb Shop sign string in Link to the Past as a remnant of some sort of hint, as in, the string for the sign was originally spoken by either girl. --Mariofan5000 09:45, 25 August 2013 (EDT)

Kholdstare Melting Shell restoration patch

Currently the download for this patch does not work. Is there anyone who could fix it or does know about other sources for the file? The preceding unsigned comment was added by Blurayno (talk • contribs)

I looked into this, and it appears that there's a bug in the site currently that prevents it from being downloaded. I'll provide a temporary link in the mean time that will work soon. The preceding unsigned comment was added by MathOnNapkins (talk • contribs)

Out of curiosity, I don't suppose it would be possible to convert the patch to a Game Genie code, would it? Specifically, a Game Genie code of five lines or fewer, so as to be used on a real Super NES Game Genie and not just an emulator. (Sadly, unlike the NES Game Genie, you can only use one Super NES Game Genie at once.)

Just wondering, 'cause while I do have the Game Boy Advance version of A Link to the Past, I feel that the original Super NES version is vastly superior — but I also still want this fix, which would be extremely difficult (for me, at least) to permanently apply to the physical cartridge that I own.

(And yes, I realize I could just play the patched ROM in an emulator, but that's not the point. I want to have the minor cosmetic fix on the real deal! :| )

Kizul Emeraldfire (talk) 12:07, 6 July 2014 (EDT)

I haven't verified this code, but here's what I got after converting the addresses modified by the patch to Game Genie codes:
CD39-D407 + CD39-D707 + CD38-D7D7 + 8D38-D7A7
--Mattrizzle (talk) 15:08, 6 July 2014 (EDT)

Using the Full restore/Equipment upgrade code

"Hold R and press Select on Controller 1 to access to the Triforce after the fight against Ganon. Works for three save slots and with any name. " Has this been verified actually to work? I can't seem to get it working at all after trying everything, doesn't matter which revision of the game I'm playing. --Blurayno 10:11, 27 July 2013 (EDT)

Second Upgrade to the Magic Meter?

One of the somewhat recent updates to The BS Zelda HomePage is enabling something apparently unused in both A Link to the Past and Inishie no Sekiban - a second upgrade to the Magic Meter which reduces consumption to one-fourth the normal amount rather than one-half. It's probably worth looking into since I don't see it mentioned here. LinkTheLefty (talk) 15:12, 28 November 2013 (EST)

I can confirm that the game is indeed coded to allow the player to use ¼.
Punching in the Pro Action Replay code 7EF37B01 will give you the normal ½ upgrade and even updates the magic meter graphic right away. Punching in 7EF37B02, on the other hand, causes your magic to be used at half of the half upgrade's rate. The graphic stays as a ½ icon regardless of setting, though -- in fact, I don't think a ¼ graphic even exists in the base game or Ancient Stone Tablets. (I couldn't find one, anyway, but I did find the ½ one. Well... the middle section, anyway...)
Any values other than 00, 01, or 02 will cause a number of strange things to happen with the magic meter, but none of them seem beneficial... which seems to indicate that the ¼ magic upgrade was intentional and went unused. It's also worth noting that two items, the Lamp and the Magic Cape still only have double their usage while under the effects of the ¼ magic meter.
~ Doc Lithius (Info|Chat|Edits) 00:45, 27 March 2017 (EDT)

Question about duck sprites

From an old revision:

====Duck Sprites====

Quack.Fly away!

The duck has additional frames of animation that are never used - one of his wings up really high and one of him leaning back slightly, which looks like it could have been used for picking Link up and dropping him off. However, the duck never assumes either of these poses at any time.

Mariofan5000 removed the latter sprite and its info, saying "The other sprite is actually briefly used when Link lands from a flight, so brief no one seems to have noticed by now." That said, shouldn't the sprite be readded but noted as something like "While the latter sprite is used, it appears extremely briefly after Link lands from a flight."? -WarioBarker (talk) 00:25, 6 December 2013 (EST)

Added. --Mariofan5000 (talk) 10:47, 28 February 2014 (EST)

GBA Differences

Can someone add pictures of all of the differences? --Mariofan5000 (talk) 14:19, 6 March 2014 (EST)

GBA Subpage

You know, you could've change the brightness to Dark in-game. --Mariofan5000 (talk) 15:30, 13 March 2014 (EDT)

You know, you could've just taken the pictures yourself. --BMF54123 (talk) 03:56, 14 March 2014 (EDT)
Well, I could've changed the brightness in-game if I owned it, but I don't. Still, they're authentic GBA-screenshots and serve their purpose. What BMF54123 said. --Ganon (talk) 18:00, 14 March 2014 (CET)

Possible Crash Debug Text?

The Legend of Zelda Wikia's glitches list for ALttP mentions a glitch crashing the game and displaying an odd screen with "BUG" written on it:

…it is very easy to scroll out of bounds, forcing the game to crash very violently (sometimes showing a weird screen with the word "BUG" written multiple times on it). If the game crashes, saved data may become corrupted.

This could possibly be some sort of debug message. On the other hand though, it might just be a glitch pulling the word "Bug" from "Bug-Catching Net"… – GlyphStorm (talk) 22:20, 13 October 2016 (EDT)

Item Dash Glitch

"After getting the Pegasus Boots, by pressing Y + A at once you can dash while holding out an item. The item works like that, too: by using the Shovel, for example, you can dig an entire row of holes, which makes the digging minigame in the Dark World really easy."

I'm not certain, but I don't think this actually works in the digging minigame. It will make holes but not give you any items. (talk) 23:25, 3 April 2017 (EDT)

Sorry for the very late reply, but yeah, that is indeed the case. You can see a row of holes being dug without items in the example YouTube video. I've gone ahead and updated the article to use a different, more accurate example, and made a note of the exception in the Shovel's behavior. I hope I'm not stepping on anyone's toes here! —Kyargu (talk) 22:53, 29 June 2019 (EDT)

"Revisional differences" todo?

Is the "Revisional Differences" to do still necessary? (Not the original "to do", which still needs investigation, probably) It looks like the original tag was added nearly 3 years ago. Having scoured the video mentioned, I'm not really finding many more glitches that are still version-specific. (All of the out of bounds, wall clip, and dungeon exploration stuff is still in the US version of the game, at least, as is the Somaria door glitch IIRC) To the best of my memory, it doesn't seem like there's really any glitches that were patched out that aren't already covered in the article. —Rambly (talk) 09:47, 3 July 2019 (EDT)

Potential crash handler sound effect investigated

Regarding the previous TODO for the ALTTP page: "* Investigate this allegedly unused (and very loud) sound. Might be a crash handler."

After consulting with kan, I've been assured he has researched it and that the sound effects for the game have been documented; the sound in question there was not found.

The way the sound engine of the game works, if garbage input data is passed into it, it can be made to play garbage back, and that appears to be what that noise is.

The following is documented sound effect data from the game:

Expand for ALTTP Sound Effects Data

| |SFX instruments
|	ARAM : |$3E00 [0x200]
|	ROM  : |$1A:9C04
|
|ID		Vol L/R		Pitch	SRCN	ADSR	Gain	Mult
|----------------------------------------------------------------------------------------------
|$00		|$70	|$70		|$1000	|$00		|$F6	|$6A	|$B8		|$03
|$01		|$70	|$70		|$1000	|$01		|$8E	|$E0	|$B8		|$02
|$02		|$70	|$70		|$1000	|$14		|$FE	|$6A	|$B8		|$02
|$03		|$70	|$70		|$1000	|$03		|$FE	|$F8	|$B8		|$0D
|$04		|$70	|$70		|$1000	|$04		|$FE	|$6A	|$7F		|$03	
|$05		|$70	|$70		|$1000	|$02		|$FE	|$6A	|$7F		|$03
|$06		|$70	|$70		|$1000	|$05		|$FE	|$6A	|$70		|$03
|$07		|$70	|$70		|$1000	|$06		|$FE	|$6A	|$70		|$03
|$08		|$70	|$70		|$1000	|$08		|$FA	|$6A	|$70		|$03
|$09		|$70	|$70		|$1000	|$06		|$FE	|$6A	|$70		|$01
|$0A		|$70	|$70		|$1000	|$07		|$FE	|$6A	|$70		|$05
|$0B		|$70	|$70		|$1000	|$0B		|$FE	|$6A	|$B8		|$03
|$0C		|$70	|$70		|$1000	|$0C		|$FE	|$E0	|$B8		|$02
|$0D		|$70	|$70		|$1000	|$0D		|$F9	|$6E	|$B8		|$03
|$0E		|$70	|$70		|$1000	|$0E		|$FE	|$F5	|$B8		|$07
|$0F		|$70	|$70		|$1000	|$0F		|$FE	|$F5	|$B8		|$06
|$10		|$70	|$70		|$1000	|$01		|$FE	|$FC	|$B8		|$03
|$11		|$70	|$70		|$1000	|$10		|$8E	|$E0	|$B8		|$03
|$12		|$70	|$70		|$1000	|$08		|$8E	|$E0	|$B8		|$02
|$13		|$70	|$70		|$1000	|$14		|$8E	|$E0	|$B8		|$02
|$14		|$70	|$70		|$1000	|$0A		|$88	|$E0	|$B8		|$02
|$15		|$70	|$70		|$1000	|$17		|$8E	|$E0	|$B8		|$02
|$16		|$70	|$70		|$1000	|$15		|$FF	|$E0	|$B8		|$04
|$17		|$70	|$70		|$1000	|$03		|$DF	|$11	|$B8		|$0F
|$18		|$70	|$70		|$1000	|$01		|$88	|$E0	|$B8		|$01
|
|==============================================================================================
|SFX1 (WRAM |$012D)
|	ARAM : |$17C0 [0x40]
|	ROM  : |$1A:8B70
|
|ID		ADDR	INSTR (BRR)	Name
|----------------------------------------------------------------------------------------------
|$01		|$2652	|$01	|$01		Rain/Zora area
|$02		|$2662	|$01	|$01		Quiet rain (packaged with |$01 by APU)
|$03		|$2677	|$01	|$01		More rain
|$04		|$2687	|$01	|$01		Even more rain (packaged with |$03 by APU)
|$05		|$284F	---	---		Silence (OW ambience)
|$06		|$284F	---	---		Quiets ambient sound (packaged with |$05 by APU)
|$07		|$2739	|$13	|$14		Rumbling (Catfish/Turtle Rock)
|$08		|$2736	|$13	|$14		Endless rumbling (extends above; packaged with |$08 by APU)
|$09		|$1C8E	|$18	|$01		DM wind/Telepathy/Mirror??? (OW ambience)
|$0A		|$1CBC	|$18	|$01		Quiet wind (packaged with |$09 by APU)
|$0B		|$1BA3	|$0D	|$0D		Flute song (flute boy)
|$0C		|$1B62	|$0D	|$0D		Flute again (packaged with |$0B by APU)
|$0D		|$1B0E	|$0E	|$0E		Magic bat/Witch shroom
|$0E		|$1B1D	|$0E	|$0E		Short jingle (packaged with |$0D by APU)
|$0F		|$1B2C	|$0E	|$0E		Crystal get/Save and quit
|$10		|$1B3E	|$0E	|$0E		SQ sound (packaged with |$0F by APU)
|$11		|$1EAC	|$16	|$15		Choir melody (Desert tablets)
|$12		|$1EC8	|$16	|$15		Choir countermelody (packaged with |$11 by APU)
|$13		|$1AD2	|$00	|$00		Lanmo/Blind swoosh
|$14		|$1AE1	|$00	|$00		Another swoosh (packaged with |$13 by APU)
|$15		|$1AF0	|$0A	|$07		Triforce door/Pyramid hole opening
|$16		|$1AFF	|$0A	|$07		VOMP (packaged with |$15 by APU)
|$17		|$1C24	|$0D	|$0D		Flute again again (weathervane/dw)
|$18		|$1BE3	|$0D	|$0D		Why is there so much flute (packaged with |$17 by APU)
|$19		|$0000	---	---		Nothing (seems unused)
|$1A		|$0000	---	---		Nothing (seems unused, packaged with |$19 by APU though)
|$1B		|$1BA3	|$0D	|$0D		All flute and no play (seems unused)
|$1C		|$1B62	|$0D	|$0D		Makes flute a flutey flute (seems unused, packaged with |$1B by APU though)
|$1D		|$1B0E	|$0E	|$0E		Some jingle (seems unused)
|$1E		|$1B1D	|$0E	|$0E		That broken jingle again (seems unused, packaged with |$1D by APU though)
|$1F		|$1B2C	|$0E	|$0E		Crystal get again (seems unused)
|$20		|$1B3E	|$0E	|$0E		Some other jingle (seems unused, packaged with |$1F by APU though)
|
|==============================================================================================
|SFX2 (WRAM |$012E)
|	ARAM : |$1820 [0x80]
|	ROM  : |$1A:8BD0
|
|ID		ADDR	INSTR (BRR)	Name
|----------------------------------------------------------------------------------------------
|$01		|$2614	|$01	|$01		Slash
|$02		|$2625	|$01	|$01		Slash
|$03		|$2634	|$02	|$14		Slash
|$04		|$2643	|$02	|$14		Slash
|$05		|$25DD	|$06	|$05		Boom wall clink/Hammer hitting rock
|$06		|$25D7	|$03	|$03		Bombable door clink
|$07		|$25B7	|$00	|$00		Fwoosh shooting apparently
|$08		|$25E3	|$02	|$14		Arrow hitting wall
|$09		|$25AD	|$00	|$00		Boomerang whooshing
|$0A		|$25C7	|$06	|$05		Hookshot
|$0B		|$2478	|$02	|$14		Placing bomb
|$0C		|$269C	|$13	|$14		Bomb exploding/Quake/Bombos/Exploding wall
|$0D		|$2414	|$00	|$00		Powder (paired |$0D→|$3F)
|$0E		|$2404	|$00	|$00		Fire rod shot
|$0F		|$24C3	|$06	|$05		Ice rod shot
|$10		|$23FA	|$05	|$02		Hammer use
|$11		|$23F0	|$05	|$02		Hammering peg
|$12		|$23CD	|$02	|$14		Digging
|$13		|$23A0	|$0D	|$0D		Flute use (paired |$13→|$3E)
|$14		|$2380	|$07	|$06		Cape on
|$15		|$2390	|$07	|$06		Cape off/Wallmaster grab
|$16		|$232C	|$10	|$01		Staircase
|$17		|$2344	|$10	|$01		Staircase
|$18		|$2356	|$10	|$01		Staircase
|$19		|$236E	|$10	|$01		Staircase
|$1A		|$2316	|$01	|$01		Tall grass/Hammer hitting bush
|$1B		|$2307	|$11	|$10		Mire shallow water
|$1C		|$2301	|$11	|$10		Shallow water
|$1D		|$22BB	|$16	|$15		Lifting object
|$1E		|$2577	|$01	|$01		Cutting grass
|$1F		|$22E9	|$02	|$14		Item breaking
|$20		|$22DA	|$0D	|$0D		Item falling in pit
|$21		|$22CF	|$02	|$14		Bomb hitting ground/General bang
|$22		|$2107	|$05	|$02		Pushing object/Armos bounce
|$23		|$22B1	|$01	|$01		Boots dust
|$24		|$22A5	|$11	|$10		Splashing (paired |$24→|$3D)
|$25		|$2296	|$11	|$10		Mire shallow water again?
|$26		|$2844	|$15	|$17		Link taking damage
|$27		|$2252	|$0B	|$0B		Fainting
|$28		|$2287	|$11	|$10		Item splash
|$29		|$243F	|$01	|$01		Rupee refill (paired |$29→|$3B)
|$2A		|$2033	|$0C	|$0C		Fire rod shot hitting wall/Bombos spell
|$2B		|$1FF2	|$0E	|$0E		Heart beep/Text box
|$2C		|$1FD9	|$00	|$00		Sword up (paired |$2C→|$3A)
|$2D		|$20A6	|$0F	|$0F		Magic drain
|$2E		|$1FCA	|$11	|$10		GT opening (paired |$2E→|$39)
|$2F		|$1F47	|$01	|$01		GT opening/Water drain (paired |$2F→|$38)
|$30		|$1EF1	|$15	|$17		Cucco
|$31		|$20CE	|$0D	|$0D		Fairy
|$32		|$1D47	|$01	|$01		Bug net
|$33		|$1CDC	|$07	|$06		Teleport (paired |$34→|$33)
|$34		|$1F6F	|$11	|$10		Teleport (paired |$34→|$33)
|$35		|$1C67	|$13	|$14		Quake/Vitreous/Zora king/Armos/Pyramid/Lanmo (paired |$35→|$36)
|$36		|$1C64	|$13	|$14		Mire entrance (extends above; paired |$35→|$36)
|$37		|$1A43	|$0E	|$0E		Spin charged
|$38		|$1F6F	|$11	|$10		Water sound (paired |$2F→|$38)
|$39		|$1F9C	|$01	|$01		GT opening thunder (paired |$2E→|$39)
|$3A		|$1FE7	|$00	|$00		Sword up (paired |$2C→|$3A)
|$3B		|$2462	|$06	|$05		Quiet rupees (paired |$29→|$3B)
|$3C		|$1A37	|$04	|$04		Error beep
|$3D		|$22AB	|$11	|$10		Big splash (paired |$24→|$3D)
|$3E		|$23B5	|$0D	|$0D		Flute again (paired |$13→|$3E)
|$3F		|$2435	|$0D	|$0D		Powder (paired |$0D→|$3F)
|$40		|$0000	---	---		Not reachable b/c AND #|$3F (value will become |$00 and play splashes |$24/|$3D because weirdness; technically part of table)
|
|==============================================================================================
|SFX3 (WRAM |$012F)
|	ARAM : |$191C [0x80]
|	ROM  : |$1A:8CCC
|
|ID		ADDR	INSTR (BRR)	Name
|----------------------------------------------------------------------------------------------
|$01		|$1A18	|$07	|$06		Sword beam
|$02		|$254E	|$01	|$01		TR opening
|$03		|$224A	|$13	|$14		Pyramid hole
|$04		|$220E	|$12	|$08		Angry soldier
|$05		|$25B7	|$00	|$00		Lynel shot/Javelin toss
|$06		|$21F5	|$02	|$14		BNC swing/Phantom ganon/Helma tail/Arrghus swoosh
|$07		|$223D	|$0C	|$0C		Cannon fire
|$08		|$21E6	|$0C	|$0C		Damage to enemy; |$0BEX.4=1
|$09		|$21C1	|$0C	|$0C		Enemy death
|$0A		|$21A9	|$03	|$03		Collecting rupee
|$0B		|$2198	|$0B	|$0B		Collecting heart
|$0C		|$218E	|$0D	|$0D		Non-blank text character
|$0D		|$21B5	|$0E	|$0E		HUD heart (used explicitly by sanc heart?)
|$0E		|$2182	|$02	|$14		Opening chest
|$0F		|$24B9	|$0B	|$0B		♪Do do do doooooo♫ (paired |$0F→|$3C→|$3D→|$3E→|$3F)
|$10		|$216D	|$0E	|$0E		Opening/Closing map (paired |$10→|$3B)
|$11		|$214F	|$07	|$06		Opening item menu/Bomb shop guy breathing
|$12		|$215E	|$07	|$06		Closing item menu/Bomb shop guy breathing
|$13		|$213B	|$0D	|$0D		Throwing object (sprites use it as well)/Stalfos jump
|$14		|$246C	|$06	|$05		Key door/Trinecks/Dash key landing/Stalfos Knight collapse
|$15		|$212F	|$13	|$14		Door closing/OW door opening/Chest opening (w/ |$29 in |$012E)
|$16		|$2123	|$13	|$14		Armos Knight thud
|$17		|$25A6	|$08	|$08		Rat squeak
|$18		|$20DD	|$05	|$02		Dragging/Mantle moving
|$19		|$250A	|$07	|$06		Fireball/Laser shot; Somehow used by Trinexx???
|$1A		|$1E8A	|$0F	|$0F		Chest reveal jingle (paired |$1A→|$38)
|$1B		|$20B6	|$0E	|$0E		Puzzle jingle (paired |$1B→|$3A)
|$1C		|$1A62	|$0A	|$07		Damage to enemy
|$1D		|$20A6	|$0F	|$0F		Potion refill/Magic drain
|$1E		|$2091	|$01	|$01		Flapping (Duck/Cucco swarm/Ganon bats/Keese/Raven/Vulture)
|$1F		|$204B	|$16	|$15		Link falling
|$20		|$276C	|$0F	|$0F		Menu/Text cursor moved
|$21		|$27E2	|$14	|$0A		Damage to boss
|$22		|$26CF	|$14	|$0A		Boss dying/Deleting file
|$23		|$2001	|$01	|$01		Spin attack/Medallion swoosh (paired |$23→|$39)
|$24		|$2043	|$0D	|$0D		OW map perspective change
|$25		|$1E9D	|$13	|$14		Pressure switch
|$26		|$1E7B	|$00	|$00		Lightning/Game over/Laser/Ganon bat/Trinexx lunge
|$27		|$1E40	|$07	|$06		Agahnim charge
|$28		|$26F7	|$07	|$06		Agahnim/Ganon teleport
|$29		|$1E21	|$07	|$06		Agahnim shot
|$2A		|$1E12	|$0A	|$07		Somaria/Byrna/Ether spell/Helma fire ball
|$2B		|$1DF3	|$0A	|$07		Electrocution
|$2C		|$1DC0	|$0A	|$07		Bees
|$2D		|$1DA9	|$0F	|$0F		Milestone, also via text (paired |$2D→|$37)
|$2E		|$1D5D	|$0B	|$0B		Collecting heart container (paired |$2E→|$35→|$34)
|$2F		|$1D80	|$0E	|$0E		Collecting absorbable key (paired |$2F→|$33)
|$30		|$1B53	|$03	|$03		Byrna spark/Item plop/Magic bat zap/Blob emerge
|$31		|$1ACA	|$01	|$01		Sprite falling/Moldorm shuffle
|$32		|$1A78	|$04	|$04		Bumper boing/Somaria punt/Blob transmutation/Sprite boings
|$33		|$1D93	|$0E	|$0E		Jingle (paired |$2F→|$33)
|$34		|$1D66	|$0B	|$0B		Depressing jingle (paired |$2E→|$35→|$34)
|$35		|$1D73	|$0B	|$0B		Ugly jingle (paired |$2E→|$35→|$34)
|$36		|$1AA7	|$07	|$06		Wizzrobe shot/Helma fireball split/Mothula beam/Blue balls
|$37		|$1DB4	|$0F	|$0F		Dinky jingle (paired |$2D→|$37)
|$38		|$1E93	|$13	|$14		Apathetic jingle (paired |$1A→|$38)
|$39		|$2017	|$07	|$06		Quiet swish (paired |$23→|$39)
|$3A		|$20C0	|$0E	|$0E		Defective jingle (paired |$1B→|$3A)
|$3B		|$2176	|$0E	|$0E		Petulant jingle (paired |$10→|$3B)
|$3C		|$248A	|$0B	|$0B		Triumphant jingle (paired |$0F→|$3C→|$3D→|$3E→|$3F)
|$3D		|$2494	|$0B	|$0B		Less triumphant jingle (|$0F→|$3C→|$3D→|$3E→|$3F)
|$3E		|$249E	|$05	|$02		"You tried, I guess" jingle (paired |$0F→|$3C→|$3D→|$3E→|$3F)
|$3F		|$2480	|$0B	|$0B		"You didn't really try" jingle (paired |$0F→|$3C→|$3D→|$3E→|$3F)
|$40		|$0000	---	---		Not reachable b/c AND #|$3F (value will become |$00 and play brokenness; technically part of table)

There are only 3F sound effects because in the latter 2 sets the top 2 bits are used for panning, and 0 means don’t play. You can technically get sfx 00 to play, but it’s not a valid pointer and is part of other data. You can see that set 1 only documents up to $20, and that’s because that’s all there is. It can technically go up to SFX FF, but its pointers table only has the $20 entries. After that is a table of pairings for the sfx. There is also not anything specifically set to play when the game crashes.

(Source: kan)

The preceding unsigned comment was added by BlackTelomeres (talk • contribs)

Changing game phase with Pro Action Replay cheat

This can be done in an emulator, and possibly on real hardware. I discovered this by accident while trying to find the memory address for the sword's strength so I could cheat my way to a stronger sword at the start of the game. The game's phase is set at the memory address 0x7EF3C5. There are 5 phases (4 of which can happen normally in the game). These are the following:

Phase 0) In normal gameplay, this phase occurs when the game has just started, but you haven't gotten your uncle's sword yet. There's rain, and guards block all path's other than the path needed to reach your first goal. You can't equip any sword or shield, even if you use a cheat that sets your sword and shield values to be greater than 0.

Phase 1) In normal gameplay, the game switches to this phase when you get your uncle's sword and shield from talking to him. Everything else seems to be the same as in phase 0, but now you can equip any sword or shield using other cheats.

Phase 2) In normal gameplay, the game switches to this phase when you have brought Zelda to the sanctuary. In this phase, there's no rain, and no guards blocking any paths.

Phase 3) In normal gameplay, the game switches to this phase after you defeat Agahnim the first time, though some elements of it also are present right after you grab the master sword. These changes mostly involve what enemies spawn, and where. There are more enemies in this phase than in other phases.

Phase 4) This phase can be achieved by setting the value in the above mentioned memory address to 4 or higher (I've tested 4 and 255, but most likely other values greater than 4 also work), but I don't think it can be achieved in normal gameplay, unless maybe this happens to be the game phase that is used during the ending demo (where it shows life in Hyrule returning to normal). In this phase, the guards are present around Link's house, again, preventing getting out of the screen where link's house and the castle are. However, there's no rain falling here.


Note that while you can clear the rain effect by setting phase to 2 or higher, if your actual game progress is less than phase 2, this memory location isn't the only thing affecting rain. If you actually have progressed to phase 2 or higher in the game, setting the phase back to 0 or 1 doesn't restart the rain graphics, but the rain sound does come back. Also, note that whether or not Zelda contacts you telepathically is not changed by this memory location. Also note that if you set the phase too high or too low than what your actual amount of game progress is, you will find that it attempts to load enemy characters for which the graphics aren't configured, so they display as glitched sprites. It seems that some other variable selects the graphics for the game phase, so there's not one single variable that controls all aspects of the game's phase. Rather, making progress in the game seems to set the values for multiple variables, of which I've only identified one so far. This impacts both the light world and dark world. Also this impacts AREAS of the game. If you are not expected to access certain parts portions of the map in specific phases (either in dark world or light world) and you set the phase to something that indicates a game phase during which it would actually be impossible to access that part of the map in normal game play, the graphics of the loaded enemy characters can be incorrect.

I had assumed that NO ENEMIES would be loaded at all outside of Link's house and castle region of the game during the first 2 phases. However, if you cheat to set the phase back to 0 or 1 after getting out of that region of the map through normal game progress (or alternatively cheat to get out of that region without progressing past it in normal game play), you can get outside the region during the early phases. I did this, and I found my assumption was MOSTLY correct about where enemies were loaded. However, in the master sword region, just north of the woods, I found that in these early 2 phases, there is an enemy that appears there, that appears in no other phase of the game. I don't know what enemy it is though, as the graphics for that enemy's sprite are glitched.

The preceding unsigned comment was added by Videogamer555 (talk • contribs)